Über unsMediaKontaktImpressum
13. Januar 2015

Ubuntu Security Update (LibYAML)

Mehrere Sicherheitslücken wurden in Ubuntu behoben. Betroffen sind:

  • Ubuntu 14.10
  • Ubuntu 14.04 LTS
  • Ubuntu 12.04 LTS

Anwendungen, die PyYAML nutzen, können mit speziellen Eingaben zu einem Crash über einen Denial of Service (DoS) gebracht werden.

Betroffen ist PyYAML, YAML parser und emitter für Python.

Folgende Versionen enthalten Korrekturen:

  • Ubuntu 14.10:
    python-yaml 3.11-1ubuntu0.1
    python3-yaml 3.11-1ubuntu0.1
  • Ubuntu 14.04 LTS:
    python-yaml 3.10-4ubuntu0.1
    python3-yaml 3.10-4ubuntu0.1
  • Ubuntu 12.04 LTS:
    python-yaml 3.10-2ubuntu0.1
    python3-yaml 3.10-2ubuntu0.1

Nach einem Update ist ein Reboot erforderlich, um alle Änderungen an PyYAML zu aktivieren.

Referenzen:
http://www.ubuntu.com/usn/usn-2461-3 CVE-2014-9130

Package Informationen:
https://launchpad.net/ubuntu/+source/pyyaml/3.11-1ubuntu0.1
https://launchpad.net/ubuntu/+source/pyyaml/3.10-4ubuntu0.1
https://launchpad.net/ubuntu/+source/pyyaml/3.10-2ubuntu0.1

Sie möchten zukünftig per Newsletter der Informatik Aktuell informiert werden? Hier können Sie sich anmelden.

botMessage_toctoc_comments_9210